upgrade postgresql-8.1 to postgresql-8.3 in debian etch

postgresql-8.3 available for etch on backports repositories. Add to /etc/apt/sources.list

deb http://www.backports.org/debian etch-backports main contrib non-free

then install postgresql-8.3

#apt-get -t etch-backports install postgresql-8.3
#pg_dropcluster --stop 8.3 main
#pg_upgradecluster 8.1 main
#pg_dropcluster --stop 8.1 main
#apt-get remove postgresql-8.1


read more